wood burning stoves*
The moose likes Other Application Frameworks and the fly likes Disable Hibernate Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Frameworks » Other Application Frameworks
Bookmark "Disable Hibernate" Watch "Disable Hibernate" New topic
Author

Disable Hibernate

arief hidayat
Ranch Hand

Joined: Apr 13, 2007
Posts: 33
Hi,

I am using Spring framework 2 on my NetBeans 5.5.1
For JPA, I am using TopLink.

when I run my application on Tomcat 5.5, First access to database is fine..
next one.. it throw.. error like this
INFO [org.simtech.iBoem.B2Bi.B2BService] - Start subscribing
WARN [org.hibernate.connection.UserSuppliedConnectionProvider] - No connection properties specified - the user must supply JDBC connections
ERROR [org.simtech.iBoem.B2Bi.B2BService] - Error WS: org.hibernate.HibernateException: Hibernate Dialect must be explicitly set

I dont use Hibernate in my apps.. I thing the spring automatically load it.
Anyone know how to disable Hibernate so that my JPA toplink can work?

thanks,
arief
Jeremy Wilson
Ranch Hand

Joined: Feb 18, 2003
Posts: 166
check for a persistence.xml file on the classpath. There may be a hibernate reference in there.


Jeremy Wilson
arief hidayat
Ranch Hand

Joined: Apr 13, 2007
Posts: 33
Originally posted by Jeremy Wilson:
check for a persistence.xml file on the classpath. There may be a hibernate reference in there.


No hibernate.. it's all using TopLink, and the references are all from TopLink.



Never mind.. I solve my problem without disabling Hibernate..

I disable TopLink cache, and the error does not show up anymore.
I don't know why it could be like that. My deadline approaching, the most important thing is that the component working fine now. hehehe..

Anyway thanks.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Disable Hibernate