aspose file tools*
The moose likes EJB and other Java EE Technologies and the fly likes EJB 2.0 AND EJB 3.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "EJB 2.0 AND EJB 3.0" Watch "EJB 2.0 AND EJB 3.0" New topic
Author

EJB 2.0 AND EJB 3.0

vipul bondugula
Ranch Hand

Joined: Oct 14, 2010
Posts: 218
Hi,

Currently My application has ejb 2.0 and web 2.5. we want to use ejb 3.0 with ejb 2.0 module. I mean, we do not want to create a separate module for ejb 3.0. Already existing ejb 2.0 module we want to use. i hav written a sample application. When deployed ejb 3.0 is not recognizing. ejb 2.0 is working fine. Please tell me whether we can use ejb 3.0 in the ejb 2.0 module

Thanks
Vipul


Thanks
Vipul Kumar
Ranganathan Kaliyur Mannar
Bartender

Joined: Oct 16, 2003
Posts: 1075
    
  10

Hi vipul,
Your question is quite confusing. I think you need to use the right terms.

Note that, the ear which will have both the jar and the war file will have a version which would be 1.4 in your case. You can find this from the application.xml file.

So, when you are upgrading, the JEE version will be 5 or 6 - so your ear will be like 5 or 6 - lets say 5. This would mean you can use EJB 3.0 and I think servlet will continue to be 2.5
So, when you deploy a JEE 5 application, you can continue to use ejb 2.0 as the severs generally support older versions.

What is the error you are getting? what is the server you are deploying against?


Ranga.
SCJP 1.4, OCMJEA/SCEA 5.0.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: EJB 2.0 AND EJB 3.0
 
Similar Threads
Help: upgrading my existing application from Weblogic 9.x to 10.0
EJB 2.0 Vs. EJB 3.0
Welcome to our author of the week
WHY EJB 3.0
RAD 7.0 SUPORT FOR STRTS 2. AND EJB 3.0