wood burning stoves 2.0*
The moose likes Sockets and Internet Protocols and the fly likes Not able to invoke UI in an IPv6 network Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Sockets and Internet Protocols
Bookmark "Not able to invoke UI in an IPv6 network" Watch "Not able to invoke UI in an IPv6 network" New topic
Author

Not able to invoke UI in an IPv6 network

nimish kumar
Ranch Hand

Joined: Dec 04, 2009
Posts: 56
Hi,

I have an issue in invoking UI on unix. We used different x-servers but still not able to invoke UI. We are working in IPv6 network. When invoking UI it gives error –
Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using 'blrkec255673d:0.0' as the value of the DISPLAY variable.
at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)

Export variable is set explicitly. Same works fine in IPv4 network.
Also, if I do a ‘telnet’ from unix to the windows port where my x-server is running, it gives me error as – connection refused. I am able to ‘telnet’ to other ports on windows from unix. I tried with different x-servers, ‘telnet’ to the ports where x-server is listening is not happening in all cases.
Any suggestion/help would be appreciated. We are stuck on this.

Regards,
Nimish

IBM-IBM WebSphere Application Server Network Deployment V7.0, Core Administration.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Not able to invoke UI in an IPv6 network
 
Similar Threads
How can my program tunnel
How to use LDAP server via Proxy?
Differnces
Error Sending Message to Web Service
Run a gui from unix box on my pc.