This week's book giveaway is in the Mac OS forum.
We're giving away four copies of a choice of "Take Control of Upgrading to Yosemite" or "Take Control of Automating Your Mac" and have Joe Kissell on-line!
See this thread for details.
The moose likes BEA/Weblogic and the fly likes Adding libraries to a cluster - weblogic Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Adding libraries to a cluster - weblogic" Watch "Adding libraries to a cluster - weblogic" New topic
Author

Adding libraries to a cluster - weblogic

hari gutta
Ranch Hand

Joined: Mar 03, 2013
Posts: 33

Hello,

I want to add libraries to the weblogic server cluster, but not to the domain. Since my domain has different clusters, and each cluster uses different versions of struts applications which other teams needs to deploy.

So how can I add libraries to the cluster alone? Is it the way we add shared libraries i.e deploying them like any other war/ear file in weblogic?
But there are many common libraries likes commons-beanutils,commons-lang etc which I added in weblogic_domain lib, without which my deployment shows some errors. So I need to move this jar files to cluster, do I need to add these basic libraries also as shared libraries?? Since other teams use different versions in these jar files also.

Thanks,
Niharika
Ramakanta Sahoo
Ranch Hand

Joined: Aug 23, 2008
Posts: 254

you can use the "deploy as library option" in weblogic console and target it to the particular cluster you want to deploy the jars


Regards, Ricky
Oracle Weblogic 10g Certified Expert TechPaste.Com
hari gutta
Ranch Hand

Joined: Mar 03, 2013
Posts: 33
Ramakanta Sahoo wrote:you can use the "deploy as library option" in weblogic console and target it to the particular cluster you want to deploy the jars



Thanks a lot for the reply.

I already tried to deploy it as a shared library and reference it in weblogic.xml since mine is jus war file..But I get the below exception

An error occurred during activation of changes, please see the log for details.
Failed to load webapp: 'DCGTools.war'
Error: Unresolved Webapp Library references for "ServletContext@23514323[appCGTools moduleCGTools.war path:/Monitor spec-version:null]", defined in weblogic.xml [Extension-Name: jwg, Specification-Version: 1, exact-match: false]

My web.xml has the following library embedded :

<wls:library-ref>
<wls:library-name>jwg</wls:library-name>
<wls:specification-version>1.0</wls:specification-version>
<wls:exact-match>false</wls:exact-match>
</wls:library-ref>

Here jwg.jar is deployed in admin console, and it is deployed successfully (I believe)
The METAINF-MF file in jwg.jar is shown below :

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.7.1
Created-By: 20.1-b02 (Sun Microsystems Inc.)
Specification-Title: JWG
Specification-Version: 1.0
Implementation-Title: JWG Implementation
Implementation-Version: 1.0
Extension-Name: jwg
Built-By: XXXXXXX
Built-Date: Tue-May-14-2013-05:10:57:PM:Eastern Daylight Time
Release-Number: N/A
Build-Cycle: N/A

Name: common
Project: emailbuild
Organization: XXXXXXXXX
Context: jwg/jwg/jar

The location of jwg.jar is "C:\ Oracle\ Middleware\ wlserver_10. 3\ common\ deployable-libraries\ jwg. jar".

Could you help me in figuring out where I am facing an issue ?

I did the same for jstl, which worked. Do you think the reason I am observing the error is, jwg is manually created and does it need to be registered some where else??
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Adding libraries to a cluster - weblogic