aspose file tools*
The moose likes BEA/Weblogic and the fly likes Issue with remote debug on Weblogic 10.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Issue with remote debug on Weblogic 10.0" Watch "Issue with remote debug on Weblogic 10.0" New topic
Author

Issue with remote debug on Weblogic 10.0

Rajkamal Pillai
Ranch Hand

Joined: Mar 02, 2005
Posts: 443
    
    1


I am trying to remote debug an application deployed on Weblogic 10.0 using Intellij IDEA 8.1.2
The application executable (CLASS files) reside on the remote box and the source files (JAVA files) are available on my local box.
(Modules -> Local source files, Libraries -> Remote jar files).

The server has been configured and started in DEVELOPMENT mode.
Am able to start the debugger and connect to the remote JVM.

The problem is that execution does not stop at the breakpoints.

How can this issue be resolved.

Rajkamal Pillai
Ranch Hand

Joined: Mar 02, 2005
Posts: 443
    
    1

I think I was trying to climb up the wrong tree :-D

Using Intellij IDEA I created a new Debug Configuration:
Run/Debug Configurations - + icon - WebLogic Instance
Application Server - I browse to the root folder for the remote WebLogic installation: "Directory '*********/******' is not BEA home"

I am not able to find a BEA_HOME environmental variable on the remote box. Which folder is the root for a WebLogic installation?


 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Issue with remote debug on Weblogic 10.0