File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes General Computing and the fly likes Eclipse Public License Compatibility Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Java Interview Guide this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Engineering » General Computing
Bookmark "Eclipse Public License Compatibility" Watch "Eclipse Public License Compatibility" New topic

Eclipse Public License Compatibility

Gaurav Gupta Ser

Joined: Dec 22, 2012
Posts: 6
I'm developing an open source project which is using library and script distributed under the following license -

1- Eclipse Public License - v 1.0
2- Apache 2.0 License
3- Dual licensed under MIT License or the GPL Version 2 License

a) Is Eclipse Public License Compatibility with Dual License (MIT & GPL) ?
b) Is Apache 2.0 License Compatibility with Dual License (MIT & GPL) ?
c) Is it suitable to distribute code under Apache 2.0 or Eclipse Public License v 1.0?
I agree. Here's the link:
subject: Eclipse Public License Compatibility
It's not a secret anymore!