wood burning stoves 2.0*
The moose likes JSF and the fly likes JSF: Jscolor stops working after first postback of fresh deploy Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » JSF
Bookmark "JSF: Jscolor stops working after first postback of fresh deploy" Watch "JSF: Jscolor stops working after first postback of fresh deploy" New topic
Author

JSF: Jscolor stops working after first postback of fresh deploy

Petr Dusek
Greenhorn

Joined: Nov 26, 2012
Posts: 23


Could anyone tell me something helpful to the following behavior in JSF with Jscolor component?

I have got this simple xhtml code:



TestBean.java:


If I do the first deployment and click on the "server" button, the Jscolor will go away and does not work (it is like destroying the javascript on the page)! If I then reload the page and click on the same button, the Jscolor works normally. There's no exception in server log, nor any error in Firebug JS console. How is this caused and how can I solve it?

Thank you!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JSF: Jscolor stops working after first postback of fresh deploy
 
Similar Threads
Managed bean is immediately called on page load
What does "Content is being hidden from the validator based on namespace filtering" mean?
Query regarding xhtml page run in JSF1.2
Button action problem in richfaces
Trying to change <ui:include> src tag dinamically