wood burning stoves 2.0*
The moose likes Object Relational Mapping and the fly likes java.io.FileNotFoundException: ServletContext resource [/xml/dbconfig.cfg.xml] cannot be resolved to Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Databases » Object Relational Mapping
Bookmark "java.io.FileNotFoundException: ServletContext resource [/xml/dbconfig.cfg.xml] cannot be resolved to" Watch "java.io.FileNotFoundException: ServletContext resource [/xml/dbconfig.cfg.xml] cannot be resolved to" New topic
Author

java.io.FileNotFoundException: ServletContext resource [/xml/dbconfig.cfg.xml] cannot be resolved to

raghu rama
Greenhorn

Joined: Dec 20, 2012
Posts: 12
Hi all
I am new to hibernate, I am using Spring and Hibernate for my application.In my application i am using two different data sources.,hence other than hibernate config.xml, i am having one dbconfig.cfg.xml file
I have specified the following tag for my sessionFactory in my springapp-servlet.xml ,





I am using Ant to build my project, though i have placed my file dbconfig.cfg.xml file in the path WEB-INF\classes\xml ,i am still getting the following error
Following is the stack trace which i get in the Weblogic log ,when i try to access my application


P.S:
I tried pasting the file in the src path like hibernateconfig.xml file ,but that too didnt work.

The stack trace




Can anyone please suggest me a solution? thank you in advance




 
It is sorta covered in the JavaRanch Style Guide.
 
subject: java.io.FileNotFoundException: ServletContext resource [/xml/dbconfig.cfg.xml] cannot be resolved to
 
Similar Threads
ActionErrors validate() method gives null pointer exception error.........
Internal Server Error due to NullPointerException while running the app.
Parsing error processing resource path Exception
Finding the java file of the compiled jsp file in Weblogic 9.2
Webservice goes down after redeploy