aspose file tools*
The moose likes JSP and the fly likes jstl are not working Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSP
Bookmark "jstl are not working" Watch "jstl are not working" New topic
Author

jstl are not working

av ravi kumar
Greenhorn

Joined: Jun 20, 2013
Posts: 6
I am running the application in tomcat 7.0.39. JSTLs are not working if i put extends attribute in page directive, coming null pointer exception. If i remove extends then application is working as expected. Please suggest did i miss any configurations from application or server side.
Thanks in advance.
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61612
    
  67

av ravi kumar wrote:Please suggest did i miss any configurations from application or server side.

How would we know as you haven't told us anything about what you've done?


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
av ravi kumar
Greenhorn

Joined: Jun 20, 2013
Posts: 6
I didn't do any configuration changes for running jstl, except putting the jstl jar file to /web-inf/lib. I want to do any configuration changes for running jstl files apart from putting jstl library?
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61612
    
  67

You need to declare it on each page. (Or define a prelude that does it.)
av ravi kumar
Greenhorn

Joined: Jun 20, 2013
Posts: 6
and adding the <taglib> tag in jsp file.
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61612
    
  67

Are you using the correct URI?

At this point, if you're not going to post code, there's not much help we can offer. Post an SSCCE that demonstrates the problem.
 
wood burning stoves
 
subject: jstl are not working