GeeCON Prague 2014*
The moose likes Tomcat and the fly likes need help with tomcat 7 socket bind failed. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » Tomcat
Bookmark "need help with tomcat 7 socket bind failed. " Watch "need help with tomcat 7 socket bind failed. " New topic
Author

need help with tomcat 7 socket bind failed.

Albert Park
Greenhorn

Joined: Feb 01, 2012
Posts: 28
Hello everyone,

I know this was brought up many times before. I just can't seem to figure out what the problem is.
Tomcat works fine when I run localhost:8080.
But this error keeps coming up everytime I start tomcat.
I am not using IDE. I am starting tomcat directly from bin.
I have tried different port number in server.xml, also got a fresh tomcat, checked netstat make sure nothing is running before I start, tried restarting my computer, checked that java isn't running in process.
Also tried with tomcat 6.
But none of these help me get rid of socket bind failed that comes up in console.

The problem I have is that I am trying to test ssl, but it isn't working. Mind you I literally tried everything online.
I am assuming that this socking bind error is the root of the problem.

Here is my log of fresh Tomcat7 without any changes to xml.

William Brogden
Author and all-around good cowpoke
Rancher

Joined: Mar 22, 2000
Posts: 12792
    
    5


Sure looks like something else is already using the 8443 port.

Perhaps there is something odd about your configuration of connectors in the server.xml file.

Bill
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: need help with tomcat 7 socket bind failed.