File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Web Services and the fly likes  Deployment error: The module has not been deployed. See the server log for more details. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark " Deployment error: The module has not been deployed. See the server log for more details." Watch " Deployment error: The module has not been deployed. See the server log for more details." New topic
Author

Deployment error: The module has not been deployed. See the server log for more details.

Jane Nelson
Greenhorn

Joined: Jun 10, 2013
Posts: 4
Hi I'm a little new to netbeans in terms of using it for web based operations so I was following a tutorial on web services and I'm having trouble deploying a web service on GlassFish Server 4.0

My error in build-impl.xml file is

<target if="netbeans.home" name="-run-deploy-nb">
<nbdeploy clientUrlPart="${client.urlPart}" debugmode="false" forceRedeploy="${forceRedeploy}"/>
</target>



The error states:

In-place deployment at C:\...(path to file)......\build\web
Initializing...
deploy?DEFAULT=C:\...(path to file)......\build\web&name=AffableBean&contextroot=/AffableBean&force=true failed on GlassFish Server 4.0
Error occurred during deployment: Exception while deploying the app [AffableBean] : Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.5.0.v20130507-3faac2b): org.eclipse.persistence.exceptions.DatabaseException
Internal Exception: java.sql.SQLException: Error in allocating a connection. Cause: Connection could not be allocated because: Access denied for user 'root'@'localhost' (using password: YES)
Error Code: 0. Please see server.log for more details.
C:\....(path to file).....\build-impl.xml:1033: The module has not been deployed.
See the server log for details.
BUILD FAILED (total time: 8 seconds)

francesco umani
Greenhorn

Joined: Aug 07, 2013
Posts: 27
If you are using a jdbc pool on glassfish you should try if it's working using the ping function from the admin console.
Rich Li
Greenhorn

Joined: Jul 09, 2013
Posts: 7
I had the same problem(I using NetBeans7.4 + glassfish4), and after experiencing painful and trying for some time, I solved this issue in the end.

update file name AffableBean->Server Resources->sun-resources.xml to glassfish-resource.xml, and using the following to replace the content of xml.
the resource-ref is for my local jdbc connector, you may need to change to yours.


<resources>
<jdbc-resource enabled="true" jndi-name="jdbc/affablebean" object-type="user" pool-name="AffableBeanPool">
<description/>
</jdbc-resource>
<jdbc-connection-pool allow-non-component-callers="false" associate-with-thread="false" connection-creation-retry-attempts="0" connection-creation-retry-interval-in-seconds="10" connection-leak-reclaim="false" connection-leak-timeout-in-seconds="0" connection-validation-method="table" datasource-classname="com.mysql.jdbc.jdbc2.optional.MysqlDataSource" fail-all-connections="false" idle-timeout-in-seconds="300" is-connection-validation-required="false" is-isolation-level-guaranteed="true" lazy-connection-association="false" lazy-connection-enlistment="false" match-connections="false" max-connection-usage-count="0" max-pool-size="32" max-wait-time-in-millis="60000" name="AffableBeanPool" non-transactional-connections="false" ping="false" pool-resize-quantity="2" pooling="true" res-type="javax.sql.DataSource" statement-cache-size="0" statement-leak-reclaim="false" statement-leak-timeout-in-seconds="0" statement-timeout-in-seconds="-1" steady-pool-size="8" validate-atmost-once-period-in-seconds="0" wrap-jdbc-objects="true">
<property name="URL" value="jdbc:mysql://localhost:3306/affablebean?zeroDateTimeBehavior=convertToNull"/>
<property name="User" value="root"/>
<property name="Password" value="xxxx"/>
</jdbc-connection-pool>
</resources>

Hope it will help.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Deployment error: The module has not been deployed. See the server log for more details.