• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Processing e-mail htm attachment but displayed with spaces

 
T. Huizt
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello

Trying to autoprocess e-mail attachement but the text is shown seperated with spaces.
Suspecting something with codepages but as I'm totally unfamiliar with this have no idea how to solve it.
Big friend Google didn't help much here.
Anyone knows how to solve this issue ?

any help greatly appreciated.






Wanted to display a sample result of the code above the forum rules don't allow that.
 
Richard Tookey
Bartender
Posts: 1166
17
Java Linux Netbeans IDE
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The chances are that the encoding is one of the two byte per characters encodings such as "utf16" so to test the theory you could try


The actual character encoding is normally available in the charset field of the content type..



 
Rob Spoor
Sheriff
Pie
Posts: 20514
54
Chrome Eclipse IDE Java Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Also: Available Doesn't Do What You Think It Does also applies for ready(). Rewrite your loop:
 
T. Huizt
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Richard,

Thanks very much for your solution as it solved my issue.

Also Rob, thanks for your remark.

T.
 
Richard Tookey
Bartender
Posts: 1166
17
Java Linux Netbeans IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
T. Huizt wrote:
Thanks very much for your solution as it solved my issue.


If you just used "utf16" and have not extract the actual character encoding from the content type then you have just created a bomb that will go off sometime in the future.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic