aspose file tools*
The moose likes EJB and other Java EE Technologies and the fly likes EJB3 not working in Weblogic 10.3 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Java » EJB and other Java EE Technologies
Bookmark "EJB3 not working in Weblogic 10.3" Watch "EJB3 not working in Weblogic 10.3" New topic
Author

EJB3 not working in Weblogic 10.3

Dimpu S Chinnu
Greenhorn

Joined: Jul 18, 2013
Posts: 5
Hi friends,

Server is running without errors after installation, but after executing the below code it starts showing same error always as
java.io.FileNotFoundException: D:\SRS - JAVA Success 2013\Softie Installed - 2013\Weblogic 10.3\bea10\user_projects\domains\srsdomain\config\config.xml (Access is denied
)...

HelloRemote.java


HelloBean.java


HelloRemote.java



ERROR:


java.io.FileNotFoundException: D:\SRS - JAVA Success 2013\Softie Installed - 2013\Weblogic 10.3\bea10\user_projects\domains\srsdomain\config\config.xml (Access is denied
)
at java.io.FileOutputStream.open(Native Method)
at java.io.FileOutputStream.<init>(FileOutputStream.java:179)
at java.io.FileOutputStream.<init>(FileOutputStream.java:131)
at weblogic.utils.FileUtils.writeToFile(FileUtils.java:115)
at weblogic.utils.FileUtils.copy(FileUtils.java:239)
at weblogic.utils.FileUtils.copy(FileUtils.java:257)
at weblogic.utils.FileUtils.copy(FileUtils.java:217)
at weblogic.utils.FileUtils.copy(FileUtils.java:158)
at weblogic.deploy.internal.targetserver.datamanagement.ConfigBackupRecoveryManager.restoreFromBackup(ConfigBackupRecoveryManager.java:64)
at weblogic.deploy.internal.targetserver.datamanagement.ConfigRecoveryService.start(ConfigRecoveryService.java:30)
at weblogic.t3.srvr.ServerServicesManager.startService(ServerServicesManager.java:459)
at weblogic.t3.srvr.ServerServicesManager.startInStandbyState(ServerServicesManager.java:164)
at weblogic.t3.srvr.T3Srvr.initializeStandby(T3Srvr.java:711)
at weblogic.t3.srvr.T3Srvr.startup(T3Srvr.java:482)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:440)
at weblogic.Server.main(Server.java:67)



please help me to solve this probelm.

thanks in advance.
francesco umani
Greenhorn

Joined: Aug 07, 2013
Posts: 27
Does D:\SRS - JAVA Success 2013\Softie Installed - 2013\Weblogic 10.3\bea10\user_projects\domains\srsdomain\config\config.xml exist?
If yes, you should try to change file permissions.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: EJB3 not working in Weblogic 10.3