wood burning stoves 2.0*
The moose likes IDEs, Version Control and other tools and the fly likes Eclipse warning: [options] bootstrap class path not set in conjunction with -source 1.6 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Eclipse warning: [options] bootstrap class path not set in conjunction with -source 1.6" Watch "Eclipse warning: [options] bootstrap class path not set in conjunction with -source 1.6" New topic
Author

Eclipse warning: [options] bootstrap class path not set in conjunction with -source 1.6

Lou Pelagalli
Ranch Hand

Joined: Nov 11, 2003
Posts: 150
    
    1
Hi,

When I use Eclipse Galileo to generate javadoc I get the warning "warning: [options] bootstrap class path not set in conjunction with -source 1.6".

I was using Java 6 but now I'm using Java 7 but I haven't been able to explain this to Eclipse.

The Javadoc Generation pane (attached) does not give me the option to add 1.7. I can type in 1.7 and the warning is gone but the 1.7 is not saved.

Suggestions?

Thanks,

Lou


[Thumbnail for Javadoc Warning.JPG]

Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16019
    
  20

The current Eclipse version is Juno. Galileo is horribly outdated, so it's not surprising that there's no Java 7 support.

I think it's about time to update your Eclipse.


Customer surveys are for companies who didn't pay proper attention to begin with.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5823
    
    7

Actually, the latest release is Kepler :-)
New versions of Eclipse come out yearly, around the end of June, beginning of July. I usually find it very worthwhile to upgrade right away.


JBoss In Action
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16019
    
  20

Dang! Now I'm out-of-date. Darned astronomical events!
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Eclipse warning: [options] bootstrap class path not set in conjunction with -source 1.6