• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Error while running my first spring application

 
Thiru Sowri
Greenhorn
Posts: 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have a beans.xml file

What is the significance of the following lines?

I tried changing the value of "http://www.springframework.org/schema/beans/spring-beans-3.0.xsd" to spring-beans-4.0.xsd and it is throwing errors like the following:


Why is it running fine when I have spring-beans-3.0.xsd or spring-beans-2.5.xsd. But throwing errors when I have spring-beans-4.0.xsd. Please explain.

thanks,
thiru
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34071
331
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That is the version number of Spring. For example, Spring 3 or 2.5

There is no Spring 4.0 available yet. There is a development version of Spring 4.0, but it isn't completed yet. If you are learning Spring, I recommend you use Spring 3 at this time. It is stable and comes with lots of documentation, tutorials and help online.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic