Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Maven Postman plugin failing to email report

 
Dave Nice
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am having some trouble getting the Maven Postman plugin to mail my surefire test report. I'm a beginner so there is likely an obvious mistake here. I will post my POM file below in case it shows any obvious cause. I have tried running clean, site, deploy and, although the report is generated, it does not get mailed. I'm not clear which maven goal I should be running to get the report generated. Any help much appreciated.


 
Dave Nice
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
anyone!?
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What OS are you using? (Programmatic email is different depending on the OS)

I assume that you have access to the mail server mentioned, that you are using the correct credentials, and that there is no firewall blocking port 995? If you are trying this from work and your company is of a reasonable size, most likely the port is being blocked by your IT department.

Also, try running with the -X option and see what output your are getting for the send-mail goal.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic