aspose file tools*
The moose likes JForum and the fly likes JForum LDAP Authentication Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » JForum
Bookmark "JForum LDAP Authentication" Watch "JForum LDAP Authentication" New topic
Author

JForum LDAP Authentication

Abdul Muzani
Greenhorn

Joined: Aug 22, 2013
Posts: 1
Hi All,

I'm new here, and to java apps.

I have JForums installed in production environment. It is installed in Tomcat 7.

In the GlobalConfig.properties i have this :
# #######
# LDAP
# #######

ldap.security.protocol =

ldap.authentication = simple

ldap.factory = com.sun.jndi.ldap.LdapCtxFactory

ldap.principal = CN=<A user in ldap>,OU=A,OU=B,DC=corp,DC=domain,DC=co,DC=id

ldap.credentials = the above user's password

ldap.server.url = ldap://corp.domain.co.id:389

ldap.field.email = mail

ldap.field.username = sAMAccountName

ldap.search.root = CN=<A user group's CN>OU=C,OU=D,DC=corp,DC=domain,DC=co,DC=id
ldap.principal = CN=<A user gorup's CN>

The LDAPAuthtenticator.class is attached.

The problem is when user is trying to log in it returns :

java.lang.NullPointerException

Using the same class, this doesn't happen in my local testing environment, staging, and dev. Only prod.
What could be the problem here?


[LDAPAuthenticator.jpg]

Jeanne Boyarsky
author & internet detective
Marshal

Joined: May 26, 2003
Posts: 30762
    
156

Abdul,
Welcome to CodeRanch!

Can you post the full stack trace of the NullPointerException?


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
 
jQuery in Action, 2nd edition
 
subject: JForum LDAP Authentication