Meaningless Drivel is fun!*
The moose likes Other Open Source Projects and the fly likes Eclipse, NoClassDefFoundError:  java/lang/Object Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Products » Other Open Source Projects
Bookmark "Eclipse, NoClassDefFoundError:  java/lang/Object" Watch "Eclipse, NoClassDefFoundError:  java/lang/Object" New topic
Author

Eclipse, NoClassDefFoundError: java/lang/Object

Irene Db
Greenhorn

Joined: Jan 31, 2002
Posts: 13
I can compile project (yes, rt.jar is included in the classpath), but getting exception when running or debugging:
Error occurred during initialization of VM
java/lang/NoClassDefFoundError: java/lang/Object
What could it be?
Barry Gaunt
Ranch Hand

Joined: Aug 03, 2002
Posts: 7729
What version of Eclipse are you using, and on what operating system platform? And what Java version?
Have you created the simplest possible application and tried that?
Have you tried to unzip the Eclipse distribution one more time and trying it again from scratch?

By the way Irene, would you please take a look at JavaRanch's Naming Policy and change your displayed name accordingly.
Thanks,
-Barry


Ask a Meaningful Question and HowToAskQuestionsOnJavaRanch
Getting someone to think and try something out is much more useful than just telling them the answer.
Dom Rodrigues
Greenhorn

Joined: Feb 26, 2004
Posts: 1
Eclipse is not able to find tools.jar due to conflicting JREs and/or SDK. Add $JAVA_HOME/lib/tools.jar to the and build classpath. Hope that helps
C. Nimo
Ranch Hand

Joined: Mar 23, 2004
Posts: 82
Eclipse lost its JRE definition.
in your project->properties->build path
select the 'libraries' tab, and then the button 'add library'
from there - add your jre and press ok.
If 'ok' is disabled - there's some sort of a collision. read the
line at the top of the window to find out what you need to remove.
hope this helps.
nimo.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Eclipse, NoClassDefFoundError: java/lang/Object