File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Websphere and the fly likes Webservice : Issue in migrating from axis 1.4 to axis 1.6 in websphere V 8.5 (JDK 6) Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Webservice : Issue in migrating from axis 1.4 to axis 1.6 in websphere V 8.5 (JDK 6)" Watch "Webservice : Issue in migrating from axis 1.4 to axis 1.6 in websphere V 8.5 (JDK 6)" New topic
Author

Webservice : Issue in migrating from axis 1.4 to axis 1.6 in websphere V 8.5 (JDK 6)

Shefali Gupta
Greenhorn

Joined: Feb 08, 2008
Posts: 2


Can any one help us in resolving Web services security processing issue. We are upgrading one of the Java Webservice to from Axis 2.1.4.1 to Axis 2.1.6.1 and Java 6. to run under websphere 8.5
While deploying application on IBM Websphere 8.5 . we are getting the issue with certificate, its giving null vale for the X509certificate. This was working fine under websphere v 6.1 with axis 1.4 and jdk 5


Please see the log trace below:


org.apache.axis2.AxisFault: WSDoAllReceiver: security processing failed
at org.apache.rampart.handler.WSDoAllReceiver.processBasic(WSDoAllReceiver.java:216)
at org.apache.rampart.handler.WSDoAllReceiver.processMessage(WSDoAllReceiver.java:85)
at org.apache.rampart.handler.WSDoAllHandler.invoke(WSDoAllHandler.java:72)
at org.apache.axis2.engine.Phase.invokeHandler(Phase.java:340)
at org.apache.axis2.engine.Phase.invoke(Phase.java:313)
at org.apache.axis2.engine.AxisEngine.invoke(AxisEngine.java:262)
at org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:168)
at org.apache.axis2.transport.http.HTTPTransportUtils.processHTTPPostRequest(HTTPTransportUtils.java:172)
Caused by: org.apache.ws.security.WSSecurityException: The signature or decryption was invalid
at org.apache.ws.security.processor.SignatureProcessor.verifyXMLSignature(SignatureProcessor.java:389)
at org.apache.ws.security.processor.SignatureProcessor.handleToken(SignatureProcessor.java:188)
at org.apache.ws.security.WSSecurityEngine.processSecurityHeader(WSSecurityEngine.java:396)
at org.apache.ws.security.WSSecurityEngine.processSecurityHeader(WSSecurityEngine.java:304)
at org.apache.ws.security.WSSecurityEngine.processSecurityHeader(WSSecurityEngine.java:249)
at org.apache.rampart.handler.WSDoAllReceiver.processBasic(WSDoAllReceiver.java:213)
... 34 more
Caused by: java.lang.NullPointerException
at org.apache.crimson.tree.ElementNode2.getAttributeNodeNS(ElementNode2.java:432)
at org.apache.crimson.tree.ElementNode2.getAttributeNS(ElementNode2.java:409)
at org.apache.ws.security.util.WSSecurityUtil.findElementById(WSSecurityUtil.java:475)
at org.apache.ws.security.message.DOMCallbackLookup.getElement(DOMCallbackLookup.java:77)
at org.apache.ws.security.processor.SignatureProcessor.setElementsOnContext(SignatureProcessor.java:419)
at org.apache.ws.security.processor.SignatureProcessor.verifyXMLSignature(SignatureProcessor.java:363)
... 39 more
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Webservice : Issue in migrating from axis 1.4 to axis 1.6 in websphere V 8.5 (JDK 6)
 
Similar Threads
org.apache.axis2.AxisFault: The message has expired
CryptoFactory: Cannot load properties: client.properties, anyone???
AXIS2 + RAMPART Error at server side: The signature or decryption was invalid
Axis2/Rampart fails auth from WCF client, never calls password callback handler
Issue with using the Axis2 JAX-WS Client using Rampart