This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Ruby and the fly likes Problem connecting to Oracle Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Languages » Ruby
Bookmark "Problem connecting to Oracle" Watch "Problem connecting to Oracle" New topic
Author

Problem connecting to Oracle

Andrew Cane
Ranch Hand

Joined: Aug 07, 2013
Posts: 91


the above code gave me an error :
C:/test/Ruby/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`initialize': wrong number of arguments (2 for 0..1) (ArgumentError)

I've tried the connection string using above credentials with sqlplus with no problem at all.
Can anybody tell me what's causing this error?
thanks
Sumit Bisht
Ranch Hand

Joined: Jul 02, 2008
Posts: 329

Could you verify whether you are using the oracle instant client (http://www.oracle.com/technetwork/database/features/instant-client/index-097480.html).
It is required as it contains the dlls which are referenced by the ruby application.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem connecting to Oracle
 
Similar Threads
Can we disable javascript in IE programatically?
Ruby on Rails question: yaml problem with scaffold generation
JSF and Third Party Components
Database newbie question about logging in
Ruby 1.8 and MySql problem