Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Strange issue in the <div> tags in a JSP page

 
Foni kumar
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Hi All.

Here is a strange issue I am facing, the below is the problematic part of my code snippet which is working for a HTML page and showing a tree structure as output while in .jsp page it is not working. In jsp when I rectify this by putting <div id>="_treeWidgetAttach"</div> , it is printing ="_treeWidgetAttach" as output.

How can I rectify this issue as I want to create a tree structure as I can see in my HTML page , please suggest.


 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64838
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Foni kumar wrote:In jsp when I rectify this by putting <div id>="_treeWidgetAttach"</div> , it is printing ="_treeWidgetAttach" as output.

Well, yeah. Anything outside of the tag will show up as text. Did you expect something different?

How can I rectify this issue

You'll need the explain exactly what the issue is a bit more clearly.

I assume there is a bunch of JavaScript involved?
 
Foni kumar
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Bear Bibeault wrote:
Foni kumar wrote:In jsp when I rectify this by putting <div id>="_treeWidgetAttach"</div> , it is printing ="_treeWidgetAttach" as output.

Well, yeah. Anything outside of the tag will show up as text. Did you expect something different?

How can I rectify this issue

You'll need the explain exactly what the issue is a bit more clearly.

I assume there is a bunch of JavaScript involved?


Hi,
Thank you for the reply. I am trying to create a tree structure as I have pasted in the output screen attachment. and when I see the output in HTML it shows error message for this spot <div id="_treeWidgetAttach"></div> but still it shows the output tree but when I am including the same HTML code in.jsp page it shows the error message in the same spot to close the div tag but doesn't show any preview .

Why is it not displaying the output for JSP but shows output for HTML it is strange fact..Can you please tell me the reason for this issue?

errormessage.jpg
[Thumbnail for errormessage.jpg]
output screen
 
Lalit Mehra
Ranch Hand
Posts: 384
Eclipse IDE Firefox Browser Java
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Have you included the dojo libraries in your jsp page required for the tree demonstration?
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic