aspose file tools*
The moose likes JSP and the fly likes Strange issue in the <div> tags in a JSP page Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSP
Bookmark "Strange issue in the <div> tags in a JSP page" Watch "Strange issue in the <div> tags in a JSP page" New topic
Author

Strange issue in the <div> tags in a JSP page

Foni kumar
Ranch Hand

Joined: Sep 19, 2007
Posts: 66

Hi All.

Here is a strange issue I am facing, the below is the problematic part of my code snippet which is working for a HTML page and showing a tree structure as output while in .jsp page it is not working. In jsp when I rectify this by putting <div id>="_treeWidgetAttach"</div> , it is printing ="_treeWidgetAttach" as output.

How can I rectify this issue as I want to create a tree structure as I can see in my HTML page , please suggest.


Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61768
    
  67

Foni kumar wrote:In jsp when I rectify this by putting <div id>="_treeWidgetAttach"</div> , it is printing ="_treeWidgetAttach" as output.

Well, yeah. Anything outside of the tag will show up as text. Did you expect something different?

How can I rectify this issue

You'll need the explain exactly what the issue is a bit more clearly.

I assume there is a bunch of JavaScript involved?


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
Foni kumar
Ranch Hand

Joined: Sep 19, 2007
Posts: 66
Bear Bibeault wrote:
Foni kumar wrote:In jsp when I rectify this by putting <div id>="_treeWidgetAttach"</div> , it is printing ="_treeWidgetAttach" as output.

Well, yeah. Anything outside of the tag will show up as text. Did you expect something different?

How can I rectify this issue

You'll need the explain exactly what the issue is a bit more clearly.

I assume there is a bunch of JavaScript involved?


Hi,
Thank you for the reply. I am trying to create a tree structure as I have pasted in the output screen attachment. and when I see the output in HTML it shows error message for this spot <div id="_treeWidgetAttach"></div> but still it shows the output tree but when I am including the same HTML code in.jsp page it shows the error message in the same spot to close the div tag but doesn't show any preview .

Why is it not displaying the output for JSP but shows output for HTML it is strange fact..Can you please tell me the reason for this issue?




[Thumbnail for errormessage.jpg]

Lalit Mehra
Ranch Hand

Joined: Jun 08, 2010
Posts: 384

Hi,

Have you included the dojo libraries in your jsp page required for the tree demonstration?


http://plainoldjavaobject.blogspot.in
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Strange issue in the <div> tags in a JSP page