aspose file tools*
The moose likes JSP and the fly likes Button not working Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Java » JSP
Bookmark "Button not working " Watch "Button not working " New topic
Author

Button not working

jack asshailtotheking
Greenhorn

Joined: Sep 20, 2013
Posts: 1
Hi guys,
I have just deployed a web project on WAS 7.0.0.15.
In a JSP page a button is not working for some users and working for others.
I have tried a mix of javascript and java for all the validations and such. And the javascipt and the cookies too, are working for the users who faced the issue.
I saw the error logs and there are some repetitive SSL errors but I cannot comprehend what they mean.
Seems like the project blew up in my face and I cant for the life of me figure out what the hell is going on.

The SSL error come in two pairs:
The 1st one containing the 3 errors below:
com.ibm.ws.ssl.channel.impl.SSLReadServiceContent$SSLCompletedCallback.complete(SSLReadServiceContext.java:1784)
com.ibm.ws.ssl.channel.impl.SSLConnectionLink$MyReadCompletedCallback.complete(SSLConnectionLink.java:643)
com.ibm.ws.ssl.channel.impl.SSLConnectionLink.determineNextChannel(SSLConnectionLink.java:1049)
This above error pair occured twice in the logs

The 2nd pair contains the 5 errors below:
com.ibm.ws.ssl.channel.impl.SSLHandshakeIOCallback.complete(SSLHandshakeIOCallback.java:87)
com.ibm.ws.ssl.channel.impl.SSLUtils.handleHandshake(SSLUtils.java:1066)
com.ibm.ws.ssl.channel.impl.SSLConnectionLink$MyReadCompletedCallback.complete(SSLConnectionLink.java:413)
com.ibm.ws.ssl.channel.impl.SSLConnectionLink.readyInboundPostHandshake(SSLConnectionLink.java:717)
com.ibm.ws.ssl.channel.impl.SSLConnectionLink.determineNextChannel(SSLConnectionLink.java:1049)
The above error pair occured thrice in the logs


Can you please tell me why the buttons aren't working and if the server is related to errors in any way, How can I undo it.
I have the following up until now
"Cookies arent disabled"
"Global setting have been copied as a security domain"


Please respond as soon as you can!!
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Button not working