In future, while posting code, please UseCodeTags. I have added them this time for you. As you can see, the tags make the code much more easier to read and understand.
Also, you have posted in the IDE forums. Please do take out time in future to CarefullyChooseOneForum.
Moving this to the correct forum...
Put the toppings in a container than can be hidden with CSS. On the change event of a pizza choice, show the container when a choice has been made.
And speaking of choices, choose better names. name="pizza" is better than name="pi" and name="topping" is better than name="top". I can never understand this urge to mangle perfectly good words with meaningless abbreviations.
Thank you Bear for the advice. I shall change the name. I haven't put up the actual code I am working on since it is for a project. I have given proper naming there. I just wanted to get the logic to get this working. Thank you once again.