Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

XSLT is not capturing values from XML

 
nirjari patel
Ranch Hand
Posts: 386
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am trying to capture values from above XML file using XSLT below.
The values are not being captured. Why is that ? Whats wrong in here ?

Thanks
 
Paul Clapham
Sheriff
Pie
Posts: 20758
30
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Would I be correct in guessing that your Layout element is selected correctly, but none of the other elements you tried to select were shown? If so, then look carefully at how your select attribute differs in that case from all the others.

If not, then tell us the details about which values aren't appearing.
 
nirjari patel
Ranch Hand
Posts: 386
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am just new to XSLT. I don't understand your generic suggestion. Please tell me how to debug clearly and wht should be next step ?

Thanks
 
Paul Clapham
Sheriff
Pie
Posts: 20758
30
Eclipse IDE Firefox Browser MySQL Database
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Next step? No, you're right, it's necessary to debug clearly. That should be the first step. To do that, you need a clear description of the problem. So far we don't have such a thing. All we have is a vague statement "The values are not being captured". As I already suggested, you should provide us with details about what that means.
 
nirjari patel
Ranch Hand
Posts: 386
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks. I have to get some basics of XSLT first. Then I will be able to better understand this.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic