This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Web Services and the fly likes CXF: ReplyTo outbound message is not sent Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "CXF: ReplyTo outbound message is not sent" Watch "CXF: ReplyTo outbound message is not sent" New topic
Author

CXF: ReplyTo outbound message is not sent

Ewgeny Greenhorn
Greenhorn

Joined: Sep 30, 2013
Posts: 1
Hello CXF-Users,

I have got some problems with the cxf-ReplyTo-function using addressing und security functionality.

An automatically generated CXF-Server (Eclipse: wsdl2java) is working well for inbound messages.
Since the SOAP-message contains a ReplyTo-part, the outbound-Message should be send by server synchronously to the ReplyTo-address.
(The reponse message should not necesserily contain a security part).

I am using Eclipse (Juno Service Release 2) with TCP/IP-Monitor to check localhost (f.e. on port 9201) if the message is going out or not.
(replyto="http://localhost:9201/test").

I already tried to add some interceptors as described here and here

The result was that the "payload" was modified, but not the address for the outgoing message. Is there anything that should be configured in advance? Is there a thinking error?

Thanks for your reply.

Here is the SOAP-message:



cxf-beans.xml:



web.xml:




Maybe it is also a problem that the outbound message does not contain the "Address:"-Attribute..?





Thanks a lot.

Ewgeny
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: CXF: ReplyTo outbound message is not sent
 
Similar Threads
Issue with using the Axis2 JAX-WS Client using Rampart
WSSE Security in SOAP HEADER
Interoperability between WCF and WSIT
Configuring Axis2 WS Security, Rampart etc for a Web Service Client
Problem while Encrypting SOAP body using Metro