aspose file tools*
The moose likes JBoss/WildFly and the fly likes JDBC Driver configuration in JBOSS 5.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "JDBC Driver configuration in JBOSS 5.1" Watch "JDBC Driver configuration in JBOSS 5.1" New topic
Author

JDBC Driver configuration in JBOSS 5.1

J Imraan
Greenhorn

Joined: Apr 15, 2013
Posts: 4
Dear Folks,

Could you please clarify the below questions regarding the JDBC Driver Compatibility With JBOSS 5.1,

1) Can we use "jboss-5.1" with the latest version "mysql-connector-java-5.1.25-bin.jar"?

2) Can we use "jboss-5.1" with the older version "mysql-connector-java-5.0.5-bin.jar"?

3) Can we use "jboss-5.1" with the intermediate version "mysql-connector-java-5.1.18-bin.jar"?

Thanks in advance.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5836
    
    7

As far as i know the answer is yes to all three. I've used various version of the 5.0 and 5.1 mysql drivers with JBoss AS. Usually the issue is more with compatibility with mysql - use the driver that has the same version (starts with the same two digits, e.g. 5.1) as the server.


JBoss In Action
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JDBC Driver configuration in JBOSS 5.1