Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JBoss 7 debug

 
Kishen Singh Punjabi
Ranch Hand
Posts: 71
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am using JBoss 7 for running my web applications, I want to debug using the JBoss inbuilt feature.
I made a breakpoing at a line in my servlet, right clciked on my project and Debug as -> Debug on server. Though i am calling the servlet, the eclipse is not going into Debug mode and am unable to debug.

Please help. Thanks in advance.
 
E Armitage
Rancher
Posts: 989
9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did your application deploy successfully?
Is your serlvet being called at all?
 
Jaikiran Pai
Marshal
Pie
Posts: 10444
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Have you done the necessary changes/additions to the startup script of the application server to start it in debug mode?
 
Muhammad Khojaye
Ranch Hand
Posts: 449
IntelliJ IDE Java Scala
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Add given JVM args for remote debugging:

Start your eclipse with remote debugger to listening on port 8998.

Configuring Eclipse using below steps,

Start Eclipse
Go to Run -> Debug Configurations
Create a new Remote Java Application configuration
Configure the remote application's details
click Apply


I hope it helps.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic