Get your CodeRanch badge!*
The moose likes Websphere and the fly likes Create SQLServer datasources with jython script Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Create SQLServer datasources with jython script" Watch "Create SQLServer datasources with jython script" New topic
Author

Create SQLServer datasources with jython script

jeetu panwar
Greenhorn

Joined: Oct 22, 2013
Posts: 9
when i Create JAAS - J2C authentication data by jython script & test datasource connectivity it give me following error "Login failed for user ''. ClientConnectionId:a433489c-e9be-4891-b584-c87b79004661 DSRA0010E: SQL State = S0001, Error Code = 18,456" solution for it is i have to open websphere console screen & in it i have to press ok button in JAAS - J2C authentication data Screen & then if i check datasource connection it works " can any one please suggest me what i am missing in jython script.
jeetu panwar
Greenhorn

Joined: Oct 22, 2013
Posts: 9
I am creating following thing using jython script
1)jdbc provide
2) datasource
3)J2C authentication data
4)WebSphere variables for sql server 2008
but when i am testing the connectivity it give me following error "Login failed for user ''. ClientConnectionId:a433489c-e9be-4891-b584-c87b79004661 DSRA0010E: SQL State = S0001, Error Code = 18,456" [b].
Solution of that which i found is that i have to open websphere console screen and in that i have to modify J2C authentication data(e.g if i just modify any value in Description section) and save the data & then if i test datasource connectivity it works.So can any please tell me what i am missing in my jython script

 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Create SQLServer datasources with jython script
 
Similar Threads
Creating JAAS for 2 applications in same node
could not to connect to my sql server by datasource
Datasource 4 Datasource 5 in WebSphere5
Error accessing DB2 in WSAD 5.1.2(Portal Server 5.0) with version 4.0 DataSource!!
Authentication, where?