Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

http 404 servlet DefaultServlet is not available

 
Abhimanyu Rathore
Ranch Hand
Posts: 32
Java Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi guys

I know this question might have been asked a million time by now..
But i am absolutely bewildered with this constant error.

So, here its..

I have simple html form, which does an doPost to servlet(named DefaultServlet)
with 1st doPost, this is the following error




With second doPost, this is what i am getting..



On the Eclipse Editor Console.. this is what i am getting






Any help is appreciable

P.S - value of <url-pattern> in web.xml is "/DefaultServlet", where as in html form, action element is pointing to "DefaultServlet"
- Tell me if i am doing anything wrong

Thanks in advance









 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13058
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator


What is your directory layout? Especially, where is that class located. Also you might as well show the entire web.xml.

Bill
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64712
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There is a list in the ServletsFaq of things to check. Please work throughout it. It includes the check that William suggests.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic