File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Tomcat and the fly likes Can't deploy a WAR file Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Can Watch "Can New topic

Can't deploy a WAR file

Michael Sorbera

Joined: Dec 06, 2013
Posts: 2
Hello everyone! First post, be gentle - yes I've researched this for over two hours before coming here...

Trying to deploy a WAR file in 7.0.47 on a windows 7 64 bit box. Tomcat server starts fine, I drop the war into the webapps directory and nothing happens. I tried going into the Manager App, WAR file to deploy section, clicked on Choose File, browsed to war file, deploy, and I get the error:

HTTP Status 500 - org.apache.tomcat.util.http.fileupload.FileUploadBase$SizeLimitExceededException: the request was rejected because its size (119990380) exceeds the configured maximum (52428800)

I went into the manager/WEB-INF/web.xml and up'd the values for max-file-size and max-request-size. Restarted server, still same error.

My Java Virtual Machine setting is pointing to: C:\Program Files\Java\jdk1.6.0_21\jre\bin\server\jvm.dll

I tried pointing it to other versions of the jvm.dll I have and still same error.

I tried adding those setting to the host-manager and ROOT web.xml's, still the same error. (yes, i restarted my server each time)

I even tried rebooting my pc...the microsoft fix for everything!

Anyone care to lend some wisdom? Got to get this working...must keep swimming, must keep swimming...

Michael Sorbera

Joined: Dec 06, 2013
Posts: 2
Found the problem - I had three instances of Tomcat on my box, I was updating the wrong web.xml.

See ya round!
Bear Bibeault
Author and ninkuma

Joined: Jan 10, 2002
Posts: 63865

Thanks for checking back in with your findings!

[Asking smart questions] [About Bear] [Books by Bear]
I agree. Here's the link:
subject: Can't deploy a WAR file
It's not a secret anymore!