wood burning stoves 2.0*
The moose likes Scala and the fly likes Play framework configuration issue Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Languages » Scala
Bookmark "Play framework configuration issue" Watch "Play framework configuration issue" New topic
Author

Play framework configuration issue

Joe Harry
Ranch Hand

Joined: Sep 26, 2006
Posts: 9345
    
    2

In my web application that runs using the Play framework, I have a separate config file called d-prod.config and I include this file in the application.conf file as well. When I run my web app, I get the following error:



Here is my simple config file (db-prod.config)



I'm terribly confused as to why this should happen for such a simple scenario where I'm just reading a set of Strings. Any ideas? The Play documentation seems not to explain this!


SCJP 1.4, SCWCD 1.4 - Hints for you, Certified Scrum Master
Did a rm -R / to find out that I lost my entire Linux installation!
Joe Harry
Ranch Hand

Joined: Sep 26, 2006
Posts: 9345
    
    2

This looks terribly strange. I modified my config entries to look like the following to make it work.



However, if I change the entries like below:



It fails with the exception:



Looks to me like anything prefixed with db is going to go through Play framework's check for certain standard keys and if they are not present, it fails!
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Play framework configuration issue
 
Similar Threads
A few questions on web services/backends
graceful way to avoid hardcoding as400 library name in query.
WS with app that uses Ant Build
Cannot Connect to database using datasource realm
static content (css and EXT-JS JavaScript) not found 404 (SOLVED)