File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes JNLP and Web Start and the fly likes No LoginModules configured Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JNLP and Web Start
Bookmark " No LoginModules configured" Watch " No LoginModules configured" New topic
Author No LoginModules configured

Saravanakumar Jeyavel

Joined: Aug 20, 2012
Posts: 6
Hello ,

i am using jnlp to launch my application. recently updated to java 7. it was working fine, but since updated to java 7 i am getting the error No LoginModules configured webutc though all the jars are being signed correctly. Below is my jnlp file

I am using jboss 7 and the login.config.xml contains the webutc info as below.

i have been trying to solve this issue past 2 days. i really appreciate if someone suggest me how to fix this issue.


Garfield Logan

Joined: Feb 20, 2014
Posts: 1
Did you solve the problem?

I found this bug that seems related with the problem. It has a workaround, but I did not understand where I must put the code. Can anyone help?
Martin Vajsar

Joined: Aug 22, 2010
Posts: 3733

Welcome to Ranch!

I believe that the initPreLoader fix actually needs to be applied to JDK sources, so this isn't a workaround. However, the quickAndDirtyFixForProblemWithWebStartInJava7u25 method seems promising, I'd try to call it at the beginning of the main method of the program. But I'm just guessing.
I agree. Here's the link:
subject: No LoginModules configured
It's not a secret anymore!