This week's book giveaways are in the Java EE and JavaScript forums.
We're giving away four copies each of The Java EE 7 Tutorial Volume 1 or Volume 2(winners choice) and jQuery UI in Action and have the authors on-line!
See this thread and this one for details.
The moose likes XML and Related Technologies and the fly likes Substring function not working while setting in data power variable Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Engineering » XML and Related Technologies
Bookmark "Substring function not working while setting in data power variable" Watch "Substring function not working while setting in data power variable" New topic
Author

Substring function not working while setting in data power variable

Arunkumar Chinnadurai
Ranch Hand

Joined: Dec 15, 2011
Posts: 56


this is my xsl
========




Data power Error ;




In Data power

Service url and URI not setted properly
Paul Clapham
Bartender

Joined: Oct 14, 2005
Posts: 18541
    
    8

It appears that the problem is something to do with the mysterious "dp:set-variable" element. Which we don't know anything about.

Neither do we know anything about the problem. "Not splitting" isn't helpful, as that leaves an entire universe of things which might be happening instead.
Paul Clapham
Bartender

Joined: Oct 14, 2005
Posts: 18541
    
    8

If you are saying that the substring() function doesn't work, then you should post the value of the $BackendURL variable, the result of the substring() function, and what you thought the result should be.
g tsuji
Ranch Hand

Joined: Jan 18, 2011
Posts: 511
    
    3
If you mean xs:string, it should at least be written like this.
 
 
subject: Substring function not working while setting in data power variable