• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Jboss and Kerberos Error

 
Ramakanta Sahoo
Ranch Hand
Posts: 256
Fedora Firefox Browser Netbeans IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Any idea why this error comes while testing the authentication via Jboss tool kit. Followed below doc with steps attached here with. Please help me get this issue fixed.

Doc: https://access.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/5/html-single/Negotiation_User_Guide/index.html
##########################################################
IIS 7.5 As webserver : App access URL: http://vm-host1.kerberos.com:90

Jboss Server Machine Name: vm-host1.kerberos.com

Jboss server running: http://vm-host1.kerberos.com:8080

AD Domain Controller Machine: vm-domaincontroller.kerberos.com

Domain: KERBEROS.COM

All Servers are Windows Server 2008 R2 Std Edition and vm-host1.kerberos.com machine hosts Jboss application server and IIS 7.5 running on 8080 and 90 ports respectively.

IE version 8.0.7601, Jboss EAP 5.2.0

##########################################################

SECURED Test shows below error:

#########################################################################
HTTP Status 401 -

--------------------------------------------------------------------------------

type Status report

message

description This request requires HTTP authentication ().


--------------------------------------------------------------------------------

JBoss Web/2.1.13.GA-patch-01

IN JBOSS SERVER LOGS:
---------------------

#########################################################################
 
John Burgess
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ramakanta

The error suggests that your browser isn't sending a set of authentication protocols that include kerberos back to the server when it gets the SPNEGO reply.
One thing that gets people a lot is that I believe if the browser and the server are on the same machine then SPNEGO will always settle on NTLM.
If you're trying from a different machine to the server note that in IE you have to add the server url to your Local INtranet zone (See Internet Settings > Security). Chrome seems to be able to do this automatically so you might want to try using it first.

Hope this helps
john
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic