• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

maven behind proxy not working

 
David Spades
Ranch Hand
Posts: 348
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My workstation is sitting behind company proxy, and I'm using eclipse Kepler and maven m2e plugin to create a maven project. the problem is, I can't seem to connect to remote repository when adding a new jar and its dependencies from eclipse. I have set the proxy segment in settings.xml nad pretty sure it's the right settings since it would work if I go to command line and do mvn install to download the jars and dependencies. does anybody know how to solve this? do I need to apply additional setting in eclipse? thanks
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34071
331
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
David,
You shouldn't need to do anything in Eclipse; it is all controlled in your Maven settings.xml. Can you confirm in the Eclipse workspace settings that you are pointing to that settings.xml that you configured?
 
David Spades
Ranch Hand
Posts: 348
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
yes, I have set under windows --> preference --> maven to point to that particular settings.xml. am I missing something? thanks
 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34071
331
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hmm. Most companies use their own Nexus so they aren't connecting to Maven through a proxy. Eclipse does have the ability to set an internet proxy. I don't think it is used by Maven, but no harm in trying. I'd be happy to be proven wrong and have your problem be something easy to fix!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic