aspose file tools*
The moose likes Ant, Maven and Other Build Tools and the fly likes maven behind proxy not working Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "maven behind proxy not working" Watch "maven behind proxy not working" New topic
Author

maven behind proxy not working

David Spades
Ranch Hand

Joined: Feb 01, 2014
Posts: 205
My workstation is sitting behind company proxy, and I'm using eclipse Kepler and maven m2e plugin to create a maven project. the problem is, I can't seem to connect to remote repository when adding a new jar and its dependencies from eclipse. I have set the proxy segment in settings.xml nad pretty sure it's the right settings since it would work if I go to command line and do mvn install to download the jars and dependencies. does anybody know how to solve this? do I need to apply additional setting in eclipse? thanks
Jeanne Boyarsky
internet detective
Marshal

Joined: May 26, 2003
Posts: 30530
    
150

David,
You shouldn't need to do anything in Eclipse; it is all controlled in your Maven settings.xml. Can you confirm in the Eclipse workspace settings that you are pointing to that settings.xml that you configured?


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
David Spades
Ranch Hand

Joined: Feb 01, 2014
Posts: 205
yes, I have set under windows --> preference --> maven to point to that particular settings.xml. am I missing something? thanks
Jeanne Boyarsky
internet detective
Marshal

Joined: May 26, 2003
Posts: 30530
    
150

Hmm. Most companies use their own Nexus so they aren't connecting to Maven through a proxy. Eclipse does have the ability to set an internet proxy. I don't think it is used by Maven, but no harm in trying. I'd be happy to be proven wrong and have your problem be something easy to fix!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: maven behind proxy not working