permaculture playing cards*
The moose likes BEA/Weblogic and the fly likes compactability issue between web logic 10.3 and 10.3.4 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "compactability issue between web logic 10.3 and 10.3.4" Watch "compactability issue between web logic 10.3 and 10.3.4" New topic
Author

compactability issue between web logic 10.3 and 10.3.4

Vinod suryawanshi
Ranch Hand

Joined: Aug 08, 2012
Posts: 50
Hi Friends,
I am new to web logic server. Our client have web logic server 10.3.0 install in there environment. So we are trying to maintain same development environment. But we not found web logic 10.3 download link. So we decided to proceed with web logic 10.3.4.
after that we develop one application in struts2 and try to deploy it in client environment i.e. web logic 10.3.0 server. Due to backward compatibility issue, web logic server10.3.4 war file not getting deployed on web logic server 10.3.0.
So please friends, suggest me some solution like,
From where I download web logic server 10.3.0 or
how do I run war created in web logic server 10.3.4 into web logic server 10.3.0.

Thank you.
German Gonzalez-Morris
Ranch Hand

Joined: Nov 16, 2009
Posts: 153

Usually there is no backwards issues among 10.3.3 & 10.3.4, although some third party libraries may have an impact.

do you have exception with stacktrace to analyze ?



http://devwebcl.blogspot.com/
Vinod suryawanshi
Ranch Hand

Joined: Aug 08, 2012
Posts: 50
Thanks German Gonzalez-Morris for your replay.
we are geting following error when we try to deploy war.


This application is working properly in web logic 10.3.4 server, but giving above error when we try to deploy it on web logic 10.3 server.

Thanks
German Gonzalez-Morris
Ranch Hand

Joined: Nov 16, 2009
Posts: 153

it looks like your Deployment Descriptors have issues with Schema validation by message:



Therefore try to update your XML schemas to 10.3.4

Doc for weblogic.xml for 10.3.4 : http://docs.oracle.com/cd/E17904_01/web.1111/e13712/weblogic_xml.htm#i1057398

weblogic.xml Namespace Declaration and Schema Location

The correct text for the namespace declaration and schema location for the WebLogic Server weblogic.xml file is as follows.

<weblogic-web-app xmlns="http://xmlns.oracle.com/weblogic/weblogic-web-app">

 
jQuery in Action, 2nd edition
 
subject: compactability issue between web logic 10.3 and 10.3.4
 
Similar Threads
How do we configure SSL in web logic server 10.3?
JDBC/classpath URGENT!!!!!SOS
JDBC/Classpath--Urgent!!!!!!!!!!!!!! SOS
War file changes are not reflected in managed server
WebLogic 10.3.4 - Cache Issue