wood burning stoves 2.0*
The moose likes Other Open Source Projects and the fly likes Cannot find org.apache.commons.javaflow Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Other Open Source Projects
Bookmark "Cannot find org.apache.commons.javaflow" Watch "Cannot find org.apache.commons.javaflow" New topic
Author

Cannot find org.apache.commons.javaflow

vidya sagar
Ranch Hand

Joined: Mar 02, 2005
Posts: 580
I tried a sample program in Jasper reports.While compiling a program it showing a error
java.lang.NoClassDefFoundError: org/apache/commons/javaflow/bytecode/Continuable


So i tried getting a jar file from apache.org
Link

It is redirecting to some page where i cannot get the jar.

Cannot anyone help me in getting a jar from some other links.
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 41823
    
  63
Like the page says, no ready-made builds (i.e., jar files) are yet available. You can get the source form the SVN repository here.


Ping & DNS - my free Android networking tools app
vidya sagar
Ranch Hand

Joined: Mar 02, 2005
Posts: 580
In SVN repository i cannot get the appropriate jar.
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 41823
    
  63
Correct - that's what the page says quite explicitly. You have to build it from the source.
vidya sagar
Ranch Hand

Joined: Mar 02, 2005
Posts: 580
Anyway thanks Ulf.I get it from different project which uses org.apache.commons.javaflow
Sai Rama
Greenhorn

Joined: Jul 21, 2006
Posts: 2
Hi,

I am getting the same error when I try to run my java program that is accessing jasper report created using IReport. I put the following .jar files to my classpath.
1.jasperreports-1.2.0.jar
2. classes12.jar (for Oracle JDBC connection)
3. commons-beanutils-1.5.jar
4. commons-collections-2.1.jar
5. commons-digester-1.7.jar
6. commons-logging-1.0.2.jar
7. jdbc connection file (Opta2000.jar)

But still I am getting this error:
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/commons/ja
vaflow/bytecode/Continuable
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
at net.sf.jasperreports.engine.JasperFillManager.fillReport(JasperFillMa
nager.java:402)
at ReportDriver.runReport(ReportDriver.java:69)
at ReportDriver.main(ReportDriver.java:88)

Can you guys please let me know what other .jar files I need to copy/set to my classpath???

Thanks,
Rama
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Cannot find org.apache.commons.javaflow