File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JForum and the fly likes Getting Null Pointer Exception while openning /forums/forum.list Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JForum
Bookmark "Getting Null Pointer Exception while openning /forums/forum.list" Watch "Getting Null Pointer Exception while openning /forums/forum.list" New topic
Author

Getting Null Pointer Exception while openning /forums/forum.list

Eaiman Shoshi
Greenhorn

Joined: Mar 03, 2014
Posts: 5
hi,
i have installed jForum successfully. i can see that the tables are created in my DB.
but after install when i go to the /forums/forum.list page i get the bellow NO:1 error for the first time and from second time (and so on) i get the NO:2 error.
my jForum version is 2.3.5
it is working on me localhost like a charm, but it is not working on the server.

NO1:


NO:2


Can any body help me? i have been working on this problem for about 10 hours
Eaiman Shoshi
Greenhorn

Joined: Mar 03, 2014
Posts: 5
This was happening because some long time ago added jars were conflicting with the jForum's jar.
after removing the jars, the forum is now working.
Jeanne Boyarsky
author & internet detective
Marshal

Joined: May 26, 2003
Posts: 30938
    
158

Interesting. Thanks for posting the solution.

Do you remember which jars caused the problem/conflict?


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: Getting Null Pointer Exception while openning /forums/forum.list