aspose file tools
The moose likes BEA/Weblogic and the fly likes Eclipse + WebLogic: generated classes not deployed Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Head First Android this week in the Android forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Eclipse + WebLogic: generated classes not deployed" Watch "Eclipse + WebLogic: generated classes not deployed" New topic
Author

Eclipse + WebLogic: generated classes not deployed

Rob Isaacs
Greenhorn

Joined: Mar 12, 2014
Posts: 20
We're using WebLogic and Eclipse, and it works pretty well. However, we have now encountered quite a big problem.

We have some classes that are automatically generated. If we build the EAR using Maven these are included in the project's JAR file in the EAR. However, if we deploy the EAR in Eclipse, these generated classes cannot be found and we get a NoClassDefFoundError. Eclipse itself sees these generated classes just fine, and we can use them in code without any problems. Only when deploying to WebLogic is there a problem with them.

Note: we have installed Oracle WebLogic Server Tools version 6.3.0.201312191402 in our own Eclipse installation. Company policy won't allow us to use OEPE.
Rob Isaacs
Greenhorn

Joined: Mar 12, 2014
Posts: 20
I've just tried the same application in OEPE and I get the same NoClassDefFoundError.
 
jQuery in Action, 3rd edition
 
subject: Eclipse + WebLogic: generated classes not deployed
 
jQuery in Action, 3rd edition