This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes BEA/Weblogic and the fly likes Eclipse + WebLogic: generated classes not deployed Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Eclipse + WebLogic: generated classes not deployed" Watch "Eclipse + WebLogic: generated classes not deployed" New topic
Author

Eclipse + WebLogic: generated classes not deployed

Rob Isaacs
Greenhorn

Joined: Mar 12, 2014
Posts: 20
We're using WebLogic and Eclipse, and it works pretty well. However, we have now encountered quite a big problem.

We have some classes that are automatically generated. If we build the EAR using Maven these are included in the project's JAR file in the EAR. However, if we deploy the EAR in Eclipse, these generated classes cannot be found and we get a NoClassDefFoundError. Eclipse itself sees these generated classes just fine, and we can use them in code without any problems. Only when deploying to WebLogic is there a problem with them.

Note: we have installed Oracle WebLogic Server Tools version 6.3.0.201312191402 in our own Eclipse installation. Company policy won't allow us to use OEPE.
Rob Isaacs
Greenhorn

Joined: Mar 12, 2014
Posts: 20
I've just tried the same application in OEPE and I get the same NoClassDefFoundError.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse + WebLogic: generated classes not deployed
 
Similar Threads
Unbinding JNDI objects
Eclipse + JBoss - some JAR files not deployed.
debug j2ee web application using eclipse
WebLogicServer n compiling servlets n jsp
location of stub classes in weblogic