File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Hadoop and the fly likes API error when running mapreduce Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Databases » Hadoop
Bookmark "API error when running mapreduce" Watch "API error when running mapreduce" New topic

API error when running mapreduce

Gleites Pereira

Joined: Apr 03, 2014
Posts: 1
I am kind of entering in despair with this since I need hadoop asap and yet I can't find the source of the problem. In the laptop I am using I have windows 8 and I followed this tutorial s to get Hadoop 2.3.0 to work (the tutorial is for 2.2.0 but I also tried to install 2.2.0 and the problem remains). I can install and start hadoop with no issues, but whenever I try to run a mapreduce job, either the given examples or something made by myself I always get the following error

I have no idea why this might be, since I am clearly using in my mapreduce functions the correct API and yet this error happens every single time, as I said tried to reinstall this twice and even use the 2.2.0 version but the issue remains, at this stage I am open to any suggestion of what it might be.
Florian Schmedding

Joined: Apr 04, 2014
Posts: 1
See Stackoverflow - Running Hadoop with single node configuration: Execute Hadoop with admin privileges. It seems that Yarn or HDFS need to create symbolic links.
I agree. Here's the link:
subject: API error when running mapreduce
It's not a secret anymore!