GeeCON Prague 2014*
The moose likes Ant, Maven and Other Build Tools and the fly likes Error resolving version for plugin 'org.codehaus.mojo:maven-war-plugin' from the repositories ? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "Error resolving version for plugin Watch "Error resolving version for plugin New topic
Author

Error resolving version for plugin 'org.codehaus.mojo:maven-war-plugin' from the repositories ?

Peter Cong
Greenhorn

Joined: Nov 21, 2009
Posts: 24
Hi, I use eclipse indigo new version to build Seam web project with Maven integration option, after the project is created, I got this error in my POM file.

Error resolving version for plugin 'org.codehaus.mojo:maven-war-plugin' from the repositories [local (C:\Users\Jon\.m2\repository), jboss-public-repository-group (https://repository.jboss.org/nexus/content/groups/public/), central (http://repo1.maven.org/maven2)]: Plugin not found in any plugin repository

Does anybody know how to fix it? thanks a lot,
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16094
    
  21

Try asking in the Maven forum. You'll find more experts there.

Moving this thread over to the Maven forum...


Customer surveys are for companies who didn't pay proper attention to begin with.
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5835
    
    7

I think there is a typo in your POM - the group id for maven-war-plugin is org.apache.maven.plugins, not org.codehaus.mojo.


JBoss In Action
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Error resolving version for plugin 'org.codehaus.mojo:maven-war-plugin' from the repositories ?