File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes JNLP and Web Start and the fly likes javaws Segmentation fault Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JNLP and Web Start
Bookmark "javaws Segmentation fault" Watch "javaws Segmentation fault" New topic

javaws Segmentation fault

Nick Mudge

Joined: Apr 16, 2014
Posts: 1

All of a sudden I am getting the error "Segmentation fault" whenever I run javaws on any jnlp file. However if I use an additional argument in the command then it works.

For example I run this on a command line:
javaws dynamictree_webstart.jnlp

I immediately get this response:
Segmentation fault

However if I run the following command it works:
javaws -verbose dynamictree_webstart.jnlp

I am using Oracle Java 1.7.0_51 on Debian 6.

Any idea why this is happening? Is this where I should ask this question?
Claude Moore
Ranch Hand

Joined: Jun 24, 2005
Posts: 720

A segmentation fault looks more like an internal JRE error. Did you try to reinstall JRE / JDK from scratch ?
I agree. Here's the link:
subject: javaws Segmentation fault
jQuery in Action, 3rd edition