File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes BEA/Weblogic and the fly likes Deployment 'state' in development mode Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Deployment Watch "Deployment New topic
Author

Deployment 'state' in development mode

Iarla O'Riada
Ranch Hand

Joined: Oct 06, 2012
Posts: 78

I'm having an issue where my deployed service is giving a 500 error. When I look at the deployments on WebLogic, their 'State' is 'New' with health 'OK'. I could swear that they would normally have been "Running".

When I try to start them, I get the message "Start requests have been sent to the selected Deployments.", but they still appear as 'New'.

Does this indicate something wrong with my deployment? I know that in production they need to be running but not sure about development mode.

Thanks,
Ten
Paul Fink
Greenhorn

Joined: May 09, 2014
Posts: 1
There are likely more detailed errors in the server log.
Check the console & the server logs
Iarla O'Riada
Ranch Hand

Joined: Oct 06, 2012
Posts: 78


I found a JDBC connection exception (despite the sources testing fine in the WebLogic console). It turns out that some of the config necessary for this project was not complete and directory containing certs, keys and properties files wasn't available to the system. Thanks for your help moving me forward!
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Deployment 'state' in development mode