aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes Is it a bug in Eclipse 4.3 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Is it a bug in Eclipse 4.3" Watch "Is it a bug in Eclipse 4.3" New topic
Author

Is it a bug in Eclipse 4.3

Adarsh Singhal
Greenhorn

Joined: May 30, 2014
Posts: 2
I've created Dynamic Web Project in Eclipse 4.3 & then I'm trying create a Servlet but Next or Finish Button is not activated in Servlet Dialogbox. Is it a bug or I'm missing something.


[Thumbnail for bug.png]

Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61766
    
  67

I would assume that it's because you left the package blank -- servlets rarely work if they are not in an explicit package. (But I wouldn't know for sure as I don't use an IDE to generate code for me.)


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
Adarsh Singhal
Greenhorn

Joined: May 30, 2014
Posts: 2
Filling Package text field doesn't make any difference. There is default package if you leave it blank.
Jeanne Boyarsky
author & internet detective
Marshal

Joined: May 26, 2003
Posts: 31068
    
232

Adarsh,
Welcome to CodeRanch!

I just tried that wizard in Kepler. I didn't need to enter a package name (although I agree with Bear that you should.) One thing I noticed is that when I typed in the classname in the field (where you have it), the class name was automatically filled in under the bottom Class Name box.

It's really easy to create a servlet though so I think your best bet it to just create the servlet class without the wizard.


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Is it a bug in Eclipse 4.3