aspose file tools*
The moose likes BEA/Weblogic and the fly likes Weblogic Update to Opatch 13.1 results in NoClassDefFoundError Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Weblogic Update to Opatch 13.1 results in NoClassDefFoundError" Watch "Weblogic Update to Opatch 13.1 results in NoClassDefFoundError" New topic
Author

Weblogic Update to Opatch 13.1 results in NoClassDefFoundError

Alexandru Iovan
Greenhorn

Joined: Jun 02, 2014
Posts: 4
Hello,

An attempt to install a patch for Weblogic 12.1.2.0.0 pointed to update my Opatch to 13.1.0.0.0. I downloaded it from Oracle Support, patch 6880880 (the one having release 13.1.0.0.0 - p6880880_131000_Generic.zip), and followed the steps from the readme file. When testing it from the command line with 'opatch' instruction, i get:

Exception in thread "main" java.lang.NoClassDefFoundError: com/oracle/cie/gdr/external/InventoryException
at oracle.opatch.OPatch.main(OPatch.java:548)
Caused by: java.lang.ClassNotFoundException: com.oracle.cie.gdr.external.InventoryException
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
... 1 more

Has anyone encountered this, or does anyone have an idea about how to fix this? I'm fairly new to Weblogic, and I would appreciate any guidance.

Thank you!
Alexandru Iovan
Greenhorn

Joined: Jun 02, 2014
Posts: 4
Problem was solved after installing latest Weblogic with Weblogic installer, and not unpacking it from Oracle's provided zip archive.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Weblogic Update to Opatch 13.1 results in NoClassDefFoundError