This week's book giveaways are in the Java EE and JavaScript forums.
We're giving away four copies each of The Java EE 7 Tutorial Volume 1 or Volume 2(winners choice) and jQuery UI in Action and have the authors on-line!
See this thread and this one for details.
The moose likes Web Services and the fly likes WebService error IWAB0135E An unexpected error has occurred.404 Not Found Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "WebService error IWAB0135E An unexpected error has occurred.404 Not Found" Watch "WebService error IWAB0135E An unexpected error has occurred.404 Not Found" New topic
Author

WebService error IWAB0135E An unexpected error has occurred.404 Not Found

Khalid Habib
Greenhorn

Joined: Dec 22, 2012
Posts: 19
Hi guys

I have created web service

when I trigger the go button in Webservice explorer it showing me following error

IWAB0135E An unexpected error has occurred.404 Not Found

Environment :

Server : IBM Websphere application server 8.5
IDE: IBM Rational Application development (RAD) 8.5


Kindly help how to get ride of this error I am trying to resolve since 3 days but didn't succeed

Thanks
William Brogden
Author and all-around good cowpoke
Rancher

Joined: Mar 22, 2000
Posts: 12769
    
    5
I can think of two possible reasons:

1. The URL used to address the web service is incorrect - does not correspond to any App on the server so you get a 404. Doublecheck how the URL is created.

2. The web service failed to initialize due to some error - check server side logs.

Bill
Khalid Habib
Greenhorn

Joined: Dec 22, 2012
Posts: 19
Thanks dear for quick reply

When I hit the URL from Browser it shows me the response
and when I check the wsdl from SOAPUI it showing me following error

Error 404: SRVE0295E: Error reported: 404
Khalid Habib
Greenhorn

Joined: Dec 22, 2012
Posts: 19
<service name="HubUserService" >
<port name="HubUserServicePort" binding="tns:HubUserServicePortBinding" >
<soap:address location="REPLACE_WITH_ACTUAL_URL" />
</port>
</service>

I do I change this endpoint address
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: WebService error IWAB0135E An unexpected error has occurred.404 Not Found