wood burning stoves 2.0
The moose likes JDBC and Relational Databases and the fly likes Oracle 11g Database schema selection Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of REST with Spring (video course) this week in the Spring forum!
JavaRanch » Java Forums » Databases » JDBC and Relational Databases
Reply locked New topic

Oracle 11g Database schema selection

Peter Fernandes

Joined: May 21, 2008
Posts: 10
Hi All

I am using Oracle 11g express, have problem to a particular schema or workspace. How can I connect to a particular schema?

Below configuration works fine. I dont know which schema it is connecting.





<!-- Database connection settings -->

<property name="connection.driver_class">oracle.jdbc.OracleDriver</property>

<property name="connection.url">jdbcracle:thinrnelo/ornelo@localhost:1521:xe</property>

<property name="connection.databaseName">hr</property>
<property name="connection.username">ornelo</property>

<property name="connection.password">ornelo</property>

<!-- JDBC connection pool (use the built-in) -->

<property name="connection.pool_size">1</property>

<!-- SQL dialect -->

<property name="dialect">org.hibernate.dialect.OracleDialect</property>

<!-- Disable the second-level cache -->

<property name="cache.provider_class">org.hibernate.cache.NoCacheProvider</property>

<!-- Echo all executed SQL to stdout -->

<property name="show_sql">true</property>

<!-- Drop and re-create the database schema on startup -->

<property name="hbm2ddl.auto">create</property>

<!-- <mapping resource="org/hibernate/tutorial/hbm/Event.hbm.xml" /> -->

<mapping class="com.nazare.hibernate.dto.UserDetails"/>


K. Tsang

Joined: Sep 13, 2007
Posts: 3060

Topic continue in http://www.coderanch.com/t/636077/ORM/databases/Oracle-Database-schema-selection#2915949


K. Tsang JavaRanch SCJP5 SCJD OCPJP7 OCPWCD5 OCPBCD5 OCPWSD5 OCMJEA5 part 1 part 2/3
wood burning stoves
subject: Oracle 11g Database schema selection
It's not a secret anymore!