Meaningless Drivel is fun!*
The moose likes Applets and the fly likes Class does not match trust level of other classes in the same package Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Java » Applets
Bookmark "Class does not match trust level of other classes in the same package" Watch "Class does not match trust level of other classes in the same package" New topic
Author

Class does not match trust level of other classes in the same package

Aluker DeBrownti
Greenhorn

Joined: Jul 17, 2014
Posts: 3
Greetings,

I am trying to get the java applets working for a website I did not create. I finally figured out how to sign the .jar files with a valid certificate, so that seems to be in order. However, when I try to run the application, it asks if I want to "Block potentially unsafe components from being run?".
The application that it sites in the pop-up is one of the .class files used in the java applet. If I click "Don't Block", the applet still has an error and doesn't run. When I click "Show details", it says "Class does not match trust level of other classes in the same package." I'm not really sure what to
do from here, although from searching online I think it has something to do with applet consisting of mixed code.

Please Help!
Thanks
 
jQuery in Action, 2nd edition
 
subject: Class does not match trust level of other classes in the same package