aspose file tools*
The moose likes Websphere and the fly likes RAD / WebSphere - startup fails with WSVR0501E / IWAE0037E Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "RAD / WebSphere - startup fails with WSVR0501E / IWAE0037E" Watch "RAD / WebSphere - startup fails with WSVR0501E / IWAE0037E" New topic
Author

RAD / WebSphere - startup fails with WSVR0501E / IWAE0037E

Gerry Bryant
Greenhorn

Joined: Aug 06, 2014
Posts: 2
Hi Coderanchers!

Intriguing problem that maybe someone has seen. I run RAD 8.0.3 with WebSphere 7. I used to use directory c:\AAAAA to hold RAD workspaces. Doing some housekeeping on the C drive, I created a new directory for RAD workspaces (c:\BBBBB) and deleted c:\AAAAA. I launched RAD, switched to a new workspace, and let it create a workspace under c:\BBBBB. So far so good. RAD opened. Before adding any applications to the server, I started the server.

Result: It threw a FileNotFoundException looking for a workspace on the old directory which doesn't even exist on the C drive anymore (c:\AAAAA). RAD's remoteconfig.ini file has no trace of c:\AAAAA, nor does a Windows search of the entire C drive reveal c:\AAAAA.

Yet RAD seems to still be storing a reference to c:\AAAAA. Tried cleaning the server and deleting the temporary files from the Windows XP machine (1 or 2 could not be deleted because they were system files).

How do we really clean up RAD so that it doesn't remember old workspace directories and focuses only on the workspace directory we specify when launching RAD?

Thanks!

[8/6/14 8:45:13:503 PDT] 00000000 ContainerHelp E WSVR0501E: Error creating component com.ibm.ws.runtime.component.CompositionUnitMgrImpl@308c308c
com.ibm.ws.exception.RuntimeWarning: com.ibm.ws.exception.ConfigurationWarning: Failed to open C:\AAAAA\SomeWebServicesEAR
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:2055)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.start(CompositionUnitMgrImpl.java:441)
at com.ibm.ws.runtime.component.CompositionUnitImpl.start(CompositionUnitImpl.java:123)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.start(CompositionUnitMgrImpl.java:384)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.access$300(CompositionUnitMgrImpl.java:112)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl$CUInitializer.run(CompositionUnitMgrImpl.java:951)
at com.ibm.wsspi.runtime.component.WsComponentImpl$_AsynchInitializer.run(WsComponentImpl.java:349)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1604)
Caused by: com.ibm.ws.exception.ConfigurationWarning: Failed to open C:\AAAAA\SomeWebServicesEAR
at com.ibm.ws.runtime.component.DeployedApplicationImpl.initialize(DeployedApplicationImpl.java:579)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.initialize(DeployedApplicationImpl.java:419)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.initializeApplication(ApplicationMgrImpl.java:365)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:2042)
... 7 more
Caused by: org.eclipse.jst.j2ee.commonarchivecore.internal.exception.OpenFailureException: IWAE0037E Could not open C:\AAAAA\SomeWebServicesEAR
at org.eclipse.jst.j2ee.commonarchivecore.internal.impl.CommonarchiveFactoryImpl.primOpenArchive(CommonarchiveFactoryImpl.java:1616)
at org.eclipse.jst.j2ee.commonarchivecore.internal.impl.CommonarchiveFactoryImpl.openEARFile(CommonarchiveFactoryImpl.java:1203)
at com.ibm.etools.commonarchive.impl.CommonarchiveFactoryImpl.openEARFile(CommonarchiveFactoryImpl.java:612)
at com.ibm.ws.runtime.component.DeployedApplicationImpl$MappableContentsArchive.open(DeployedApplicationImpl.java:1706)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.initialize(DeployedApplicationImpl.java:576)
... 10 more
Caused by: java.io.FileNotFoundException: IWAE0036E URI Name: C:\AAAAA\SomeWebServicesEAR; File name: C:\AAAAA\SomeWebServicesEAR
at org.eclipse.jst.j2ee.commonarchivecore.internal.impl.CommonarchiveFactoryImpl.createLoadStrategy(CommonarchiveFactoryImpl.java:513)
at org.eclipse.jst.j2ee.commonarchivecore.internal.impl.CommonarchiveFactoryImpl.primOpenArchive(CommonarchiveFactoryImpl.java:1610)
... 14 more

[8/6/14 8:45:13:597 PDT] 00000000 TCPChannel I TCPC0001I: TCP Channel TCP_1 is listening on host * (IPv4) port 9061.
[8/6/14 8:45:13:738 PDT] 00000000 WSChannelFram A CHFW0019I: The Transport Channel Service has started chain WCInboundAdmin.
[8/6/14 8:45:13:738 PDT] 0000

Claude Moore
Ranch Hand

Joined: Jun 24, 2005
Posts: 500
    
    1

If you open WAS admin console, you should see that "old" Java EE projects (once on C:\aaaa, now in C:\bbbb workspace) are still listed in deployed enterprise applications, and are marked with a red "X" (it means stopped, in your case, it means that they're just not started). Simply remove via admin console them, and problem during startup should go away.
Gerry Bryant
Greenhorn

Joined: Aug 06, 2014
Posts: 2
Hi Claude,

Sorry for the delay in getting back to you. I much appreciate your time and your response.

It worked! You answered my question "How do we really clean up RAD?". As you recommeded, I went to the WAS Console and uninstalled the two applications having red Xs. Those turned out to be the ones that were not being found at server startup time. Now the server starts fine.

Thanks Claude!

Gerry
Claude Moore
Ranch Hand

Joined: Jun 24, 2005
Posts: 500
    
    1

You're welcome, Gerry.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: RAD / WebSphere - startup fails with WSVR0501E / IWAE0037E