This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Other Open Source Projects and the fly likes Jasper Reports: compile .jasper file for earlier version of Java Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » Other Open Source Projects
Bookmark "Jasper Reports: compile .jasper file for earlier version of Java" Watch "Jasper Reports: compile .jasper file for earlier version of Java" New topic
Author

Jasper Reports: compile .jasper file for earlier version of Java

David Heffington
Greenhorn

Joined: Mar 17, 2007
Posts: 17
Hi- I have a web application that runs on a Websphere box. The Websphere version is an older version that requiires JVM V.1.4. I have recently upgraded to JDK version 1.6 on my development box. For my reports, I compile the .jasper files on the development box and deploy those along with the corresponding .jrxml file to the server. Now, after I compile the .jasper files on my development box, my reports are blowing up on the server with a Java version mismatch error. I looked at the Jasper APIs and cannot find an overloaded signature of the JasperCompileManager.compileReportToFile() method that takes a version number as an argument. Does anyone know of a way to get the JasperCompileManager.compileReportToFile() method to compile for an earlier version of Java (short of reverting my JDK back to v.1.4 on my development box)?

Thanks!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Jasper Reports: compile .jasper file for earlier version of Java
 
Similar Threads
Compiling Jasper Report - need help
JSP and Jasper reports
compileing .jrxml file
Jasper reports error in weblogic 8.1
Java Compliance for Building and installing the software